Overview
Features
Download
Documentation
Community
Add-Ons & Services
The POCO C++ Libraries Blog

Archive: September, 2011

POCO C++ Libraries Patch Release 1.4.2p1 Available

Filed under: News by guenter at 17:53

This release fixes issues for some users caused by a change to Poco::SharedLibrary (use of RTLD_DEEPBIND on Linux). This change has been reverted. Instead, overloads to load() and the constructor are provided that allow flags being passed to the loader. One of the flags currently supported in SHLIB_LOCAL, resulting in dlopen() being called with RTLD_LOCAL instead of RTLD_GLOBAL, which is the default. Another bug has been fixed as well. As always, the CHANGELOG has the details. Upgrading is recommended for all users using Poco::SharedLibrary or Poco::ClassLoader.