Overview
Features
Download
Documentation
Community
Add-Ons & Services

Which versions of VMS does Poco support?

A general discussion forum.

Which versions of VMS does Poco support?

Postby marlowabnp » 20 Jan 2013, 13:25

I am currently looking into improving the Poco support for symbolic links, mainly on UNIX and Windows. For completeness I am looking at the other platforms that Poco supports. It seems like there in insufficient support for symbolic links in VxWorks but for OpenVMS it may be a different case. From version 8.3 of OpenVMS there is quite a bit of support and it seems to be basically POSIX-compliant. So in theory the code I am using in the UNIX impl classes could also be used in the VMS impl classes. Any thoughts? What versions of VMS does Poco support? What versions of VMS are people using it with? I don't want to submit a patch that requires at least version 8.3 OpenVMS if Poco users on VMS are on an older version.
marlowabnp
 
Posts: 80
Joined: 08 Nov 2010, 17:29

Re: Which versions of VMS does Poco support?

Postby alex » 20 Jan 2013, 16:45

marlowabnp wrote:Any thoughts? What versions of VMS does Poco support? What versions of VMS are people using it with? I don't want to submit a patch that requires at least version 8.3 OpenVMS if Poco users on VMS are on an older version.

Günter can chime in on this but we didn't paid much attention to OpenVMS in the recent years. Would #ifdef be to messy? That's what we do with operating systems and compilers to isolate features only available on newer versions..
alex
 
Posts: 1087
Joined: 11 Jul 2006, 16:27
Location: United_States

Re: Which versions of VMS does Poco support?

Postby guenter » 21 Jan 2013, 20:37

I basically stopped supporting OpenVMS around release 1.3. It's still in there, but not maintained anymore. Reactivating it would require some porting of newer features, as well as updating the vmsbuild files. However, I haven't seen any requests for OpenVMS support in recent years, and I don't have access to a system for testing anymore, so I'm not sure if supporting it is worth it. Except for some specific applications, OpenVMS seems to be dead. There's not much new development going on. If someone steps in to maintain the OpenVMS port, that's fine, though.
guenter
 
Posts: 1107
Joined: 11 Jul 2006, 16:27
Location: Austria

Re: Which versions of VMS does Poco support?

Postby marlowabnp » 22 Jan 2013, 12:55

guenter wrote:I basically stopped supporting OpenVMS around release 1.3. It's still in there, but not maintained anymore. Reactivating it would require some porting of newer features, as well as updating the vmsbuild files. However, I haven't seen any requests for OpenVMS support in recent years, and I don't have access to a system for testing anymore, so I'm not sure if supporting it is worth it. Except for some specific applications, OpenVMS seems to be dead. There's not much new development going on. If someone steps in to maintain the OpenVMS port, that's fine, though.
I just saw this http://sourceforge.net/news/?group_id=187340 about OpenVMS users reporting that Poco stopped support around 2008. I didn't realise. In that case I will not worry very much about the symbolic link code I am adding working on OpenVMS. I do not have access to an OpenVMS system so I cannot check that the OpenVMS impl works. I will concentrate on Windows (unicode with and without) and UNIX.
marlowabnp
 
Posts: 80
Joined: 08 Nov 2010, 17:29


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron