Overview
Features
Download
Documentation
Community
Add-Ons & Services

Visual Studio Build Problem

Please post support and help requests here.

Visual Studio Build Problem

Postby Andrew » 31 Aug 2006, 02:51

When building the Foundation part of th elibrary, I get the following error:
Performing Custom Build Step
MC: may only specify one message file to compile.
...

The problem seems to be that I have spaces in the path name. So the solution is to move the library to say C: ,build it there and then move it back.

Can this be fixed? I suspect that it is a simple matter of quoting the filename/paths for this particular command.


Thanks
Andrew
Andrew
 
Posts: 6
Joined: 30 Aug 2006, 03:55

Re: Visual Studio Build Problem

Postby guenter » 31 Aug 2006, 10:42

The fix does not seem to be that simple.
I tried adding quotes to the command line args for mc, but this causes mc to fail alltogether.

Any ideas?
guenter
 
Posts: 1107
Joined: 11 Jul 2006, 16:27
Location: Austria

Re: Visual Studio Build Problem

Postby Andrew » 02 Sep 2006, 07:55

Not really, I also tried adding quotes in the form " instead of " but it failed.
I looked at http://windowssdk.msdn.microsoft.com/en-us/library/ms734147.aspx
and the only thing that may be a clue is: "Relative paths and environment variables cannot be used when specifying a file. A Universal Naming Convention (UNC) path can be used to locate the file. Any relative path and environment variable expansion needs to be done prior to creating the command.
"

> When building the Foundation part of th elibrary, I get the following error:
> Performing Custom Build Step
> MC: may only specify one message file to compile.
> ...
>
> The problem seems to be that I have spaces in the path name. So the solution is to move the library to say C: ,build it there and then move it back.
>
> Can this be fixed? I suspect that it is a simple matter of quoting the filename/paths for this particular command.
>
>
> Thanks
> Andrew
>
Andrew
 
Posts: 6
Joined: 30 Aug 2006, 03:55

Re: Visual Studio Build Problem

Postby gdhuse » 02 Mar 2007, 17:28

To revive an old thread, I found that this works in the custom build step when building from a place with spaces in the path:

mc -h src -r src srcpocomsg.mc
gdhuse
 
Posts: 1
Joined: 28 Feb 2007, 22:53


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron