Add-Ons & Services

Building lib64

Please post support and help requests here.
Posts: 7
Joined: 08 May 2012, 21:46

Building lib64

Postby mattcox » 08 May 2012, 22:00


I'm using Visual Studio 2010 and looking to implement Poco in 32 and 64 bit builds of my app. I ran

Code: Select all

buildwin.cmd 100
and it successfully built the .lib files. However, I seem to only have the 32 bit builds of the library. I have no lib64 folder.

I took a quick look at the build script and there appears to be am argument for specifying the platform, however, it states that those flags are optional and it should by default build everything.
I tried rerunning the buildwin.cmd script and specified a x64 build. It created a lib64 folder, but according to the build log, most of the builds failed, so I am not sure if I have everything. The main error that kept cropping up was: Module machine type 'x86' conflicts with target machine type 'x64'.

Has anyone got any ideas? Is there something obvious I am missing here or should it just work?

I apologize in advance if this is an obvious question, I tried searching, but couldn't find anything.


Posts: 1234
Joined: 11 Jul 2006, 16:27
Location: United_States

Re: Building lib64

Postby alex » 16 May 2012, 03:48

Did you follow the instructions for enabling 64-bit toolset?

Posts: 7
Joined: 08 May 2012, 21:46

Re: Building lib64

Postby mattcox » 16 May 2012, 12:34


Yes. Thanks you.

I managed to get it working last night, I tried setting it up on a different machine and it worked. So something must be a bit dodgy about the visual studio installation and configuration on this machine. It's all running fine on 64 bit now though.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 1 guest