Add-Ons & Services

Exception when creating SocketServer [SOLVED]

Please post support and help requests here.

Exception when creating SocketServer [SOLVED]

Postby cosu2004 » 16 Jun 2013, 20:17

Hello guys,

I have a problem with ServerSocket when binding. For example: If I create a ServerSocket object using the constructor with port number parameter:
Code: Select all
 SharedPtr<ServerSocket> SS = new ServerSocket( 49531 );

it will throw and exception with this message: [I/O error: 0: ]. I don't understand what actually does this supose to mean? It doesen't matter if my network card is on or off or if I have a network cable inserted.
But, if I use a lower port, for example 50, or 40 it works. It manages to bind the socket.

I debugged it and I found out that the error appears at binding.

I also tried with creating a socket address, thinking that it has to be something when determining the ip, but still the same error.
Code: Select all
Poco::Net::SocketAddress tempAdr( "" );

What can this be? I used the same code on windows XP with visual studio 2008. Now I;m working on VS2010 with windows 7 pro and poco v. 1.4.6p1

Thank you!

---RESOLVED: I think it was from the Firewall...
Posts: 14
Joined: 05 Jul 2012, 10:50

Return to Support

Who is online

Users browsing this forum: No registered users and 3 guests