Overview
Features
Download
Documentation
Community
Add-Ons & Services

PocoZip is not built on OSX?

Please post support and help requests here.

PocoZip is not built on OSX?

Postby arielm » 29 Aug 2013, 10:22

Hi,

I'm on OSX 10.8, using version 1.4.6 downloaded from github.

When building using:
Code: Select all
./configure --config=Darwin32 --no-tests --no-samples
make -s

Only the following libs are built:

PocoCrypto
PocoData
PocoDataODBC
PocoDataSQLite
PocoFoundation
PocoNet
PocoXML

The problem is that PocoZip is not built, even-though it appears in the "components" list.

Note that I have also tried with:
Code: Select all
./configure --config=Darwin32-clang-libc++ --no-tests --no-samples
make -s

But without success... What do I am missing?

Thanks!
Ariel
arielm
 
Posts: 3
Joined: 29 Aug 2013, 10:05

Re: PocoZip is not built on OSX?

Postby arielm » 29 Aug 2013, 22:38

Follow-up:

Note that using the Complete Edition version 1.4.6p1 (downloaded from pocoproject.org) is yielding the same result.

Anyway, I finally ended-up using the following solution:

1) Using the Basic Edition version 1.4.6p1 (downloaded from pocoproject.org)

2) Injecting the whole Zip folder and patching the makefile so that it includes PocoZip
arielm
 
Posts: 3
Joined: 29 Aug 2013, 10:05


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron