Overview
Features
Download
Documentation
Community
Add-Ons & Services

For 1.3.3

Please post support and help requests here.

For 1.3.3

Postby cx500tc » 22 Sep 2008, 17:09

Here is my list of bugs that I hope will be fix in 1.3.3: Sorry for not reporting this ealier. These are issue with 1.3.2, but I will test with the 1.3.3 that's in the SVN repository.

In Linux/QNX6 the Poco::Net::NetworkInterface will not set the subnet and broadcast. I reported this before 1.3.2.

When compile with gcc 3.3.5 or later, in ./XML/include/Poco/SAX/AttributesImpl.h there are a bunch of warnings about comparison between signed and unsigned value. I fixed those with casting.

QNX6 being based on Dinkum library it as the same "bug" as under windows. Hence in StreamUtil.h I had to add __QNXNTO__ to the #if statement that would set poco_ios_init(buff) to a nop. Otherwise there will be memory leaks.

Under QNX6 in the script configure I had to change all the "if [ "$val" != "" ] ; then" into "if [ "$val" != "0" ] ; then". Otherwise the script would not work when it called with a parameter, any parameter

On later version of QNX (6.3.2) the compiler 3.3.2 isn't available anymore, had to change build/config/QNX to specify 3.3.5. ( 4.2.4 will be available soon)

cx500tc
 
Posts: 26
Joined: 24 Sep 2007, 17:48

Re: For 1.3.3

Postby alex » 22 Sep 2008, 18:13

> Here is my list of bugs that I hope will be fix in 1.3.3: Sorry for not reporting this ealier. These are issue with 1.3.2, but I will test with the 1.3.3 that's in the SVN repository.

After you do that, can you please post Sourceforge bug reports about the outstanding issues. It is hard to track things here.

Thanks,

Alex
alex
 
Posts: 1116
Joined: 11 Jul 2006, 16:27
Location: United_States

Re: For 1.3.3

Postby alex » 22 Sep 2008, 18:15

> QNX6 being based on Dinkum library it as the same "bug" as under windows. Hence in StreamUtil.h I had to add __QNXNTO__ to the #if statement that would set poco_ios_init(buff) to a nop. Otherwise there will be memory leaks.

Is there a way to detect whether Dinkumware library is used and whether the used version is affected with the mentioned bug? Seems like a more robust approach.

Alex
alex
 
Posts: 1116
Joined: 11 Jul 2006, 16:27
Location: United_States

Re: Re: For 1.3.3

Postby cx500tc » 22 Sep 2008, 21:59

> > Here is my list of bugs that I hope will be fix in 1.3.3: Sorry for not reporting this ealier. These are issue with 1.3.2, but I will test with the 1.3.3 that's in the SVN repository.
>
> After you do that, can you please post Sourceforge bug reports about the outstanding issues. It is hard to track things here.
>

Done.

> Thanks,
>
> Alex
>
cx500tc
 
Posts: 26
Joined: 24 Sep 2007, 17:48


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests