Overview
Features
Download
Documentation
Community
Add-Ons & Services

new ZipArchive throws exception

Please post support and help requests here.

new ZipArchive throws exception

Postby MMjns13 » 31 Oct 2013, 06:25

Hi,

I am using the Poco Zip library to access the contents of OpenXML files. Occasionally when creating a new ZipArchive it throws an exception with the message "Assertion violation: getMajorVersionNumber() <= 2". This is due to an external application setting the version number to 4.5.

Will Poco Zip libs be supporting later Zip versions and if so is there a timeline on it?

Many Thanks
MMjns13
 
Posts: 3
Joined: 31 Oct 2013, 05:52

Re: new ZipArchive throws exception

Postby guenter » 31 Oct 2013, 20:04

See <https://github.com/pocoproject/poco/issues/317>
guenter
 
Posts: 1119
Joined: 11 Jul 2006, 16:27
Location: Austria

Re: new ZipArchive throws exception

Postby MMjns13 » 17 Dec 2013, 01:18

Hi,

I see that a fix is due out in Release 1.5.3 due out in about a month. Do you have a specific date in mind?

Many Thanks
MMjns13
 
Posts: 3
Joined: 31 Oct 2013, 05:52


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron