when it's the cppunit in POCO. I know that cppunit is a huge beast for what it does, so I appreciate that POCO uses a cut-down variant. But it's not really cppunit then is is? It just resembles it. I propose that it be renamed. The trouble with calling it cppunit is that it could too easily be confused with the real cppunit.
It is possible that either one could evolve such that differences in common usage arise. For example, I would like to see the POCO unit test framework support named tests and loop asserts, used to assert conditions whilst looping through test data (where you would want to know for the constant line of source code which line of test data it was using when the assert failed).